Under Review Wiki: Table formatting

Discussion in 'Feedback/Support/Suggestions' started by thewinchester, Apr 29, 2011.  |  Print Topic

  1. thewinchester
    Original Member

    thewinchester Silver Member

    Messages:
    197
    Likes Received:
    368
    Status Points:
    470
    Have been establishing new pages for the Accor stubs, and have discovered an issue with the use of tables within the wiki.

    Due to something in the MP stylesheets, tables are being pushed right to the bottom of a page.

    This of course leaves a large amount of white space, and leaves the user scrolling to see if there's any content there.

    Examples of the problem:
    Tested and replicated on:
    • Win7 FFX 4.0.1.
    • Win7 IE 9.0.8112 Standards mode
    • Win7 IE 9.0.8112 Compatibility mode
    • Win7 Chrome 11.0.696
    • Ubuntu 11.04 FFX 4.0.1 Canocial 1.0 package
     
    lin821 and Gargoyle like this.
  2. thewinchester
    Original Member

    thewinchester Silver Member

    Messages:
    197
    Likes Received:
    368
    Status Points:
    470
  3. Gargoyle
    Original Member

    Gargoyle Milepoint Guide

    Messages:
    22,015
    Likes Received:
    96,543
    Status Points:
    20,020
    lin821 and thewinchester like this.
  4. Tim
    Original Member

    Tim Admin

    Messages:
    445
    Likes Received:
    428
    Status Points:
    525
    This is correct, these are examples of the bbcode not being entered quite right. I'll have these instances looked into. Thanks!
     
    lin821, thewinchester and Gargoyle like this.
  5. Mackieman
    Original Member

    Mackieman Gold Member

    Messages:
    11,320
    Likes Received:
    38,534
    Status Points:
    16,520
    This is correct as confirmed to me by Mikel. It is an unfortunate issue with the rendering engine that makes it exceedingly tedious to create tables. Hopefully this one gets fixed soon.
     
    lin821, thewinchester and Gargoyle like this.
  6. thewinchester
    Original Member

    thewinchester Silver Member

    Messages:
    197
    Likes Received:
    368
    Status Points:
    470
    Eek!

    Thanks for looking into this, and here's hoping it does get corrected soon because that workaround makes it a real nightmare (even if you can do text find and replaces with the best of them.
     
    lin821 likes this.
  7. ParanoiaTX
    Original Member

    ParanoiaTX Gold Member

    Messages:
    5,113
    Likes Received:
    10,302
    Status Points:
    11,070
    I've found one workaround here is to put the newline right BEFORE the [ /td ] statement. It's still ugly in the bbcode, but it allows you to at least break a table across multiple lines at (somewhat) natural boundaries. See here and here for examples.

    As for a real fix, once a [ table ] is started, all white-space really should be ignored except inside the [ td ] blocks.
     
  8. ParanoiaTX
    Original Member

    ParanoiaTX Gold Member

    Messages:
    5,113
    Likes Received:
    10,302
    Status Points:
    11,070
    Also, curious why this is marked answered and is not on the master bug list. This really doesn't seem like it's the intended behavior for tables.
     
  9. Tim
    Original Member

    Tim Admin

    Messages:
    445
    Likes Received:
    428
    Status Points:
    525
    It is the intended/known behavior currently, though we would like to change how it works most certainly. I'll add this to the suggestion list.
     

Share This Page